• 31 127 online
  • 1 129 265 medlemmar
  • 58 585 867 inlägg
2017-05-18, 02:14
  #1
Medlem
avcs avatar
För ett litet tag sedan hittade jag ett Nintendo 8-bit utomhus som har en märklig egenhet för sig: det kan fungera bra alltifrån en halvtimme till en halv dag innan det plötsligt och utan förvarning hänger sig. Detta gäller oavsett vilket spel som sitter i konsolen, och oavsett om man spelar aktivt eller bara har konsolen i "idle". Symptomen är följande:

Uppstart
Med handkontroll: Blåskärm
Utan handkontroll: Spelet startar

I spelet
Startat utan handkontroll: Fungerar felfritt
Koppla in handkontroll: Spelet hänger sig, ritar ev. upp massa tecken på skärmen
Koppla ur handkontroll: Spelet fortsätter eller har låst sig till omstart

Har provat koka (två gånger) och ultraljudstvätta (en gång) connectorn efter spel vägrat starta, vilket inledningsvis gett positivt resultat två av två gånger, och sedan blivit sämre och sämre för att slutligen inte starta alls. Har beställt en ny connector i tron att denna varit död, men nu börjar jag oroa mig för kontakten till handkontrollen eller moderkortet. Eller kan det fortfarande vara connectorn som länkar samman spelet med handkontrollen? Konsolen har legat utomhus i åratal.
Citera
2017-05-18, 02:23
  #2
Medlem
-Andreas-s avatar
Ok.
Vad händer om du provar en annan kontroll?

Det är inte connectorn det är fel på.

Edit;
Försökte hitta nåt elschema på nes men hittar bara scheman på "arduino", pc moderkort o på andra typer av mikro datorer.

Anyways.
Prova bara byta kontrollen. Låter som rätt ände att börja i, innan du börjar löda i portarna/kontakterna.

👍
__________________
Senast redigerad av -Andreas- 2017-05-18 kl. 02:45.
Citera
2017-05-18, 12:51
  #3
Moderator
BigFatCones avatar
Spel: retro --> Konsol: hårdvarusupport
/Moderator
Citera
2017-05-18, 19:54
  #4
Medlem
avcs avatar
Citat:
Ursprungligen postat av -Andreas-
Ok.
Vad händer om du provar en annan kontroll?

Det är inte connectorn det är fel på.

Edit;
Försökte hitta nåt elschema på nes men hittar bara scheman på "arduino", pc moderkort o på andra typer av mikro datorer.

Anyways.
Prova bara byta kontrollen. Låter som rätt ände att börja i, innan du börjar löda i portarna/kontakterna.

👍
Du hade helt rätt, nya connectorn dök upp idag och gjorde ingen skillnad alls. Åkte ner och köpte en ny kontroll efter connectorn monterats och den fungerar bättre, men fortfarande inte bra. Trycker man kontakten i botten hänger sig spelet, lite utanför fungerar det, dock glappigt (styrknapparna på vänster sida kan plötsligt ge upp medan B och A fortsätter fungera, till exempel).

Min gissning var först skräp/korrosion i kontakterna, men det verkar ologiskt då det inte spelar någon roll ifall jag sätter kontrollen i port 1 eller 2, då spelet hänger sig iallafall. Känns som det hela orsakar kortslutning någonstans?

Edit: Vet inte hur relevant det är, men fick hem Super Mario Bros. 1 idag, som av någon anledning körs i dubbel hastighet utan någon input från min sida. Klockat? De två andra spelen går i normal hastighet...

Edit #2: Hittade svaret nu. Skall inte bero på nån klockning utan på att det är utgåva 2 av spelet som körs snabbare.


Citat:
Ursprungligen postat av BigFatCone
Spel: retro --> Konsol: hårdvarusupport
/Moderator
Tackar
__________________
Senast redigerad av avc 2017-05-18 kl. 20:18.
Citera
2017-05-18, 20:27
  #5
Medlem
-Andreas-s avatar
Citat:
Ursprungligen postat av avc
Du hade helt rätt, nya connectorn dök upp idag och gjorde ingen skillnad alls. Åkte ner och köpte en ny kontroll efter connectorn monterats och den fungerar bättre, men fortfarande inte bra. Trycker man kontakten i botten hänger sig spelet, lite utanför fungerar det, dock glappigt (styrknapparna på vänster sida kan plötsligt ge upp medan B och A fortsätter fungera, till exempel).

Min gissning var först skräp/korrosion i kontakterna, men det verkar ologiskt då det inte spelar någon roll ifall jag sätter kontrollen i port 1 eller 2, då spelet hänger sig iallafall. Känns som det hela orsakar kortslutning någonstans?
Jo.
Om det hade varit kortslutning så borde hela konsolen typ hänga sig, så som du beskrev i TS eller att *random button "fastnar" i oändlig loop*.

Tänker mer om det kan vara så sönder ärgat i någon av tåtarna i en av ledarna, på både P1 och P2 portarna, att det _kanske_ är mer åt glappigt/dålig kontakt~ish hållet... än ren kortslutning(?)

Bild på nes moderkort;
http://www.retronintendoreviews.com/...2/IMG_1604.jpg

Schema, men nog overkill än så länge;
http://gamesx.com/wiki/lib/exe/fetch...ller-ports.png

För.
Om du tittar på första länken/bilden så är det 7 ledare, samma på elschemat, o det bästa och närmaste steget borde vara att titta så att alla 7 ledare på både P1 och P2 portarna är hyfsat hela med okulär besiktning.

[Typ kolla så de inte är helt frasiga/pulver]
Citera